<< Retour au sommaire

 

Les formules matricielles

 

 

 

Les formules matricielles permettent de simplifier certains calculs grâce à une nouvelle syntaxe.

 

En effet, si vous désirez par exemple faire la somme de la colonne A, de A2 à A10 et uniquement si les valeurs sont supérieures à 10, voici comment procéder :

 

{=SOMME(SI(A2:A10>=10;A2:A10))}

Attention, pour que cette formule puisse être considérée comme une formule matricielle et non pas comme une formule classique, vous devez la valider par le raccourci clavier :

MAJ +CTRL +Entrée.

 

Toujours dans le même exemple, pour faire la moyenne des valeurs supérieurs ou égales à 10 :

{=MOYENNE(SI(A2:A10>=10;A2:A10))}

 

Et maintenant, la moyenne des valeurs inférieures à 10 :

{=MOYENNE(SI(A2:A10<10;A2:A10))}

 

Par exemple, pour afficher le texte « ok » si l’une des valeurs comprises de a1 à J1 contient la valeur 50 :

{=SI(OU(A1:J1=50);"OK")}

 

Dans l’exemple suivant, nous avons des dépenses faites dans 2 magasins, « Leclerd » et « Carrefour ».

Les magasins sont dans la colonnes A, les dépenses dans la colonne B ».

Après le tableau, vous trouverez 2 formules, la première calcule la somme des dépenses réalisées chez « Leclerc », la seconde chez « Carrefour ».

 

magasin

Dépenses

Leclerc

9,00 €

carrefour

11,00 €

Leclerc

17,00 €

carrefour

16,00 €

leclerc

19,00 €

carrefour

22,00 €

leclerc

500,00 €

carrefour

11,00 €

leclerc

7,00 €

 

Voici la formule qui calcule la somme des dépenses dans le magasins « Leclerc » :

{=SOMME(SI(A2:A10="leclerc";B2:B10))}

Voici la formule qui calcule la somme des dépenses dans le magasins « Carrefour » :

{=SOMME(SI(A2:A10="carrefour";B2:B10))}

 

Philippe BOULANGER